Problem mit ICD2

Dieses Thema im Forum "Elektrotechnik" wurde erstellt von Oberstift, 31 März 2007.

  1. Hallo Community,
    ist hier jemand der sich mit der PIC Familie von Microchip auskennt?

    Ich habe nämlich folgendes Problem: kürzlich habe ich mir einen Nachbau der ICD2 von Microchip bei ebay gekauft da dieser wesentlich billiger war als das Original. Jetzt hab ich das Teil endlich bekommen und als ich es testen wollte kam das Erwachen. Wenn ich am PC den Button "Programmer-connect" drücke bringt er die Fehlermeldung "Failed selftest". Dass der Fehler an der Software (MPLAB IDE 7.31) liegt kann ich eigentlich ausschliessen, weil das Originalprodukt von Microchip (hab ich manchmal im Betrieb genommen) einwandfrei funktionierte.

    Hat jemand ähnliche oder die gleiche Erfahrung gemacht?
    Für sachdienliche Hinweise bin ich schon im Voraus dankbar!!!

    Grüsse vom Kaiserstuhl
     
  2. AW: Problem mit ICD2

    Hallo,

    ich habe auch so ein Ding zusammengebaut. Und Anfangs massive Probleme. Jedoch scheiterte es bei mir an der Kommunikation. Naja es war dann letztendlich ein Ätzfehler (Kurzschlussbrücke) zwischen zwei Leiterbahnen. Ärgerlich bei einer fertigen Platine. Doch jetzt funktioniert der ICD2 hervorragend.
    Bei Dir sollte die Kommunikation aber funktionieren, wenn es bereits zum Selftest kommt.

    Hat MBLAB schon das Operatingsystem heruntergeladen.
    Wenn Du beim Selftest scheiterst, dann ruf mal die "Settings" auf und kontrolliere den Status von Target-Vdd, Module-Vpp, MCLR-Gnd, MCLR-Vdd und MCLR Vpp. Hier solltest Du einen Fehler vorfinden, denn genau diese Spannungen werden beim Selftest geprüft.

    P.S.: Hast Du eine Serial -oder USB- Connection?
     
  3. AW: Problem mit ICD2

    Hallo MartinRo,
    danke erstmal für die schnelle Antwort!
    Bei mir läuft die Verbindung über USB! Woran sehe ich ob das Operatingsystem runtergeladen wurde?

    In den Settings steht:

    Target Vdd: Pass
    Module Vpp: Pass
    MCLR GND: Pass
    MCLR Vdd: Pass
    MCLR Vpp: Low

    Was jetzt?:(
     
  4. AW: Problem mit ICD2

    Hallo,


    jetzt gehst Du bei Settings zum Unterpunkt "Power". Mit Update überprüfst Du die Programmierspannung "Target Vpp". Diese sollte ca. 12V betragen. Gegebenenfalls musst Du sie nachstellen. Dazu findest Du ein Poti auf Deinem ICD2.

    Das Operatingsystem wird nur einmal runter geladen, es ist für das jeweilige Device, dass Du selektiert hast. Du kannst es prüfen wenn Du einfach einen anderen "PIC" selektierst. Dann wird die passende Software für das Device neu auf den ICD2 geschrieben.
     
    #4 MartinRo, 31 März 2007
    Zuletzt bearbeitet: 31 März 2007
  5. AW: Problem mit ICD2

    Hier mal die Verbindungssequenz mit dem ICD2, wenn ein neues Operatingsystem
    geladen wird. Die Warnung "Invalid target device ID wird ausgelöst, weil ich keinen PIC angeschlossen habe.
     

    Anhänge:

    • ICD2.JPG
      ICD2.JPG
      Dateigröße:
      42,6 KB
      Aufrufe:
      13
  6. AW: Problem mit ICD2

    Also das mit dem Operatingsystem sollte eigentlich passen! Ich habe damit noch nie etwas anderes als den PIC16F873 programmiert.

    Aber Target Vpp ist tatsächlich nur 1,84 nur sehe ich dummerweise kein Poti auf der ganzen Platine!
    Wenigstens weiss ich jetzt mal ungefär die Richtung in der der Hund begraben liegt, wenn ich dem Lieferanten mal auf die Füsse trete!;)
     
  7. AW: Problem mit ICD2

    Hallo,

    bevor Du den Lieferanten treten willst habe ich noch einige Fragen.

    Hast Du den ICD2 mit einem PIC verbunden? Wenn ja, ist er richtig angeschlossen? Hast Du das MCLR-Pin richtig beschaltet? Womöglich zieht Dir nämlich ein falscher Pin bzw. eine falsche Beschaltung am MCLR-Pin die Programmierspannung runter!

    Wenn kein PIC angeschlossen ist, haben sich die Fragen erübrigt!
     
    #7 MartinRo, 31 März 2007
    Zuletzt bearbeitet: 31 März 2007
  8. AW: Problem mit ICD2

    Ich habe es mal mit einem PIC angeschlossen und mal nur die ICD2 aber es scheiterte jedesmal am selftest. Daher gehe ich davon aus, dass der Fehler an der ICD2 selber liegt und nicht an der nachfolgenden Beschaltung!

    Ich habe aber mittlerweile schon Antwort vom Lieferanten bekommen ich kann das Teil zurückschicken und krieg dann ein neues oder das Geld!
    Wenigstens gibt es da keine Probleme aber ärgerlich ist es halt trotzdem!
     
  9. AW: Problem mit ICD2

    Mittlerweile ist das Teil bei denen mal angekmmen (in China) und ich kann mir aussuchen ob ich ein neues Gerät von denen will oder den Kaufpreis zurück.
    Hast du (oder sonst wer) ne Ahnung wo man den original ICD2 kaufen kann? Bei Microchip bekommt man ihn soweit ich gesehen hab nur in Verbindung mit der ganzen nachfolgenden Beschaltung und ca 10km USB Kabel usw. Ich bin aber nur am ICD2 selbst interessiert den Rest habe ich ja schon!

    Denn wenn ich das original zu einem einigermaßen humanen Preis haben kann würde ich mittlerweile lieber dazu greifen!

    Gruss
     
  10. AW: Problem mit ICD2

    Hallo Anubis,
    danke erstmal für deine Antwort!
    Diese Version auf der Seite ist leider auch nur ein Nachbau obwohl er mir auf den ersten Blick deutlich hochwertiger erscheint als das was ich bisher hatte!

    Mir stellt sich jetzt aber die Frage wo ich das Originalteil herbekomme also die offizielle runde Bauform. Sollte ich die irgendwo zu einem erschwinglichen Preis sehen würde ich diese nämlich bevorzugen.

    Das mit der Inbetriebnahme sollte kein Problem sein, denn ich hab die notwendige Software schon auf dem Rechner und damit auch schon PICs programmiert!

    Gruss
     
  11. AW: Problem mit ICD2

    Hallo Oberstift,

    ich weiß gar nicht wo dein Problem ist. Der Nachbau (Link) ist kompatibel zum Original. Es werden nur ein paar andere Bauteile eingesetzt. Zu dem ist die Programmierspannung einstellbar, anders als bei deinem preiswertem China-Import. Dieser Klon arbeitet mit der Original-Software.

    Aber wenn du lieber 100,- € oder mehr ausgeben möchtest. Ja, warum nicht.
    Ich habe bisher nur gute Erfahrungen mit meinem Nachbau gemacht.
     
  12. AW: Problem mit ICD2

    Ich habe mit der Zeit ein bisschen ne Abneigung gegen solche Clons entwickelt. Darum habe ich mir gesagt ich nehm die Version von Microchip direkt, wenn ich es irgendwo zu einem zahlbaren Preis finde!
    Original ist halt Original!

    Aus deinem letzten Beitrag schliesse ich, dass du das Teil selber hast!
    Wie ist es mit dem fachlichen in dem Laden?
    Habe ich da jemanden mit Sachverstand am Ohr, wenn ich da im Problemfall mal anrufe?
    Die Seite macht ja schon einen recht vielversprechenden Eindruck was die Kompetenz betrifft.

    Mein China Gerät hätte auch mit der Originalsoftware gearbeitet!
    Mit welcher Software sollte es sonst noch arbeiten können?
     

Diese Seite empfehlen