Logo Poti

Hallo,

ich habe da eine kurze Frage.

Ich habe ein Poti, der sitz im Motor; habe ein Temperurfühler. Der Motor fährt eine Klappe auf und zu.

Kann man mit dem Temperaturfühler über dem Poti die Klappe fahren?

ZB Wenn bei 100 Grad ist möchte ich die Klappe nur 50% fahren.

Bei 150 Grad möchte ich die Klappe 75% fahren.

Kann man das im Logo Programm relasieren?
 
Beispiel kann ich erst nächste Woche liefern. Schau dir mal den Baustein Analogkomperator an. Den kann man nutzen um zwei Analogwerte zu vergleichen. Vielleicht hilft ja @gunsmans mit einem Beispiel!?
 
Das Poti liefert ja 0-10V und somit super 0-100%. Den Wert des Temperaturfühlers musst du über eine Anslogarithmetik in 0-100% umrechnen. Also festlegen welche Temperatur einer Klappenstellung entsprechen soll. Diese beiden Werte führst du dann zwei Analogkomperatoren zu und zwar so das die Eingänge jeweils gegenläufig angeschlossen sind. So bekommst du von einem ein 1-Signal wenn der Potiwert höher ist und vom anderen wenn der Temperaturwert höher ist. Jetzt hast du zwei Signale mit denen du den Klappenmotor in die eine oder andere Richtung ansteuern kannst.
 
Guten Morgen,

vielen Dank.

Ich habe ein 0 bis 5 V POTI: Den muss ich dann so einstellen 0-100%. Was muss ich genau bei den Analogarithmetik einstellen.

Können sie mir ein Beispiel geben, damit ich das in mein Programm ergänzen kann
 
Bei 0-5V liefert der Analogverstärker Werte von 0-500. Im Analogverstärker dann einfach bei min 0 und bei max 500 einstellen, dann wird als Ausgabewert auch 0-1000 geliefert. Oder den Temperaturwert anpassen. Beispiel geht erst Montag Abend.
 
Wenn beim Analogverstärker der Sensortype 0-10V gewählt wird, dann muss ein Gain von 2 eingestellt werden, wenn bei 5V im Analogeingang dann 1000 Einheiten im Ausgang des Analogverstärkers sein soll.
Dafür hat der Themenstarter schon in einem anderen Thema von ihm ein Beispiel von mir bekommen.

Logo Poti 0 bis 5V
 
Danke.

Mit dem Analogverstärker habe ich verstanden. Nur mit dem Analogarithmetik, ( temperaturfühler weiß ich noch nicht wirklich wie ich das einstellen muss. die zwei Analogkomperator habe ich auch schon.

Dann warte ich auf den Montag.
 
Der Temperaturwert 100 Grad sind in der Logo 1000. bei Anzeige mit einer Nachkommastelle sind das dann 100,0 Grad. Unter dem Baustein Arithmetik ist ein kleines+ zu sehen. Klicke da drauf und es erscheint eine Tabelle mit vier Werten. An den zweiten „Anschluss „ führst du deine aktuelle Temperatur. In den Bausteineinstellungen trägst du an erste Stelle 1000 ein. Als Operation -! So bekommst du bei 0Grad 1000, also 100,0%. Damit hast Du jetzt einen Vergleichswert für das Poti.
 
Der Temperaturwert 100 Grad sind in der Logo 1000. bei Anzeige mit einer Nachkommastelle sind das dann 100,0 Grad. Unter dem Baustein Arithmetik ist ein kleines+ zu sehen. Klicke da drauf und es erscheint eine Tabelle mit vier Werten. An den zweiten „Anschluss „ führst du deine aktuelle Temperatur. In den Bausteineinstellungen trägst du an erste Stelle 1000 ein. Als Operation -! So bekommst du bei 0Grad 1000, also 100,0%. Damit hast Du jetzt einen Vergleichswert für das Poti.
 
Wie sieht denn bei dir die Temperaturmessung aus?
PT100 und AM2 RTD Modul?
Welche LOGO! hast du genau? Schreibe bitte mal die genaue Bestellnummer und Firmwareversion.

Was ist das denn für Klappe?
Wenn die Klappe in einem Rohr, hat dies kein lineares Durchlaßverhalten.
 
Ein anderer Ansatz wäre bei einer reinen Temperaturregelung der PI-Regler Baustein. Ich habe hier im Forum dazu auch schon Beispiele gepostet wo das Ausgangssignal des PI zur Ansteuerung eines Mischerventils genutzt wurde. Da das Auma Ventil eine Rückmeldung über das Poti hat, wäre das auch leicht realisierbar.
 
Da ich keine genauen Angaben als Antwort auf meine Fragen erhalte, habe ich ein Beispiel für eine 0BA8.Standard erstellt.

Leider kann ich keine Datei anhängen. Ich bekomme immer die Meldung, dass ein Serverfehler vorliegt.
 
Top