LabView/ Wago I/OSystem

Hallo,

es geht um eine Realisierung eines Projektes.
Als SPS benutze ich den WagoController 750-881 (Wago I/O-System) und möchte aber mit LabView visualisieren und programmieren.

Das Problem:
Wie kann ich eine Verbindung von LabView zum Wago Ethernet I/O herstellen?
Habe viel über OPC-Server einrichten oder Wago Modbus Driver mbt.dll Datei gelesen.

Benötige ich zusätzliche Dateien oder ist es nur eine LabView Einstellung?

Über Tipps, Ratschläge würde ich mich sehr freuen
 
AW: LabView/ Wago I/OSystem

Hallo Harry,

ich arbeite beruflich mit LabView, habe damit allerdings noch kein Wago Controller angesteuert. Das beste wäre man hat Treiber dafür. Wenn du aber schon eine .dll Datei hast, kannst du die über ein dll-Knoten ansteuern. Vielleicht helfen dir auch die anderen Menüpunkte unter "Konnektivität" in LabView.


Gruß
nameless
 
AW: LabView/ Wago I/OSystem

danke für die schnelle antwort,

das ist ja das problem, das ich keine dll datei habe und nicht weiß wie ich da ran komme.
ich weiß nur das es funktionieren soll mit lab view und wago.

google mir schon die hände wund.


aber gut zu wissen das du mit labview arbeitest. dann kann ich dich ma fragen wenn ich probleme damit habe.
wenn irgendwann die verbindung besteht.
wie wird eigentlich in labview die verbindung mit einer sps oder controller angezeigt. wann weiß ich das verbindung besteht?

MFG
 
AW: LabView/ Wago I/OSystem

Also nach meiner bisherigen Erfahrung, hängt das vom Gerät ab mit welchen Befehlen man was erreicht...bisher habe ich Messgeräte damit angesprochen und die hatten entweder Treiber oder eine Anleitung mit den Befehlen...
 
AW: LabView/ Wago I/OSystem

Hi nameless 79,

habe dll. Dateien auftreiben können, die praktisch jeweils schon ein VI (schon eingebunden) sind. Wie kann ich diese in mein eigentliches Programm einbinden? Sprich Eingänge oder Ausgänge ansteuern?

Kann man LabView auch nur zur Visualsierung benutzen und zum Beispiel mit codsys nur programmieren?
Vielleicht kannst du mir erzählen wie du deine Messgeräte einbindest. Wie kommuniziert LabView mit den Messgeräten etc.? Wie sieht dein Blockdiagramm aus?
Kann man ein websurfer mit LabView einrichten?

Danke für deine Unterstützung.
 
AW: LabView/ Wago I/OSystem

Hallo Harry,

das ist schonmal nicht schlecht, dass du ne dll hast, allerdings ist es auch nicht schlecht Informationen über die dll zu haben, sonst muss man nach dem Trial and Error vorgehen. Die dll bindet man ja mit einem dll-Knoten in LabView ein. Wenn man die Vi´s in übergeordnete Vi´s einbinden will sprich als Unterprogramm, muss man die Eingänge bzw. Ausgänge nach "außen" führen. Dazu musst du im Frontpanel des Unterprogramms rechts oben das Symbol mit der rechten Maustaste anklicken und "Anschluss anzeigen" anwählen, dann kannst wieder mit der rechten Maustaste entweder Muster aussuchen oder Ein- oder Ausgänge hinzufügen bzw. entfernen. Wenn du jetzt mit der linken Maustaste einen Ein- oder Ausgang anwählst, kannst du Objekte auf dem Frontpanel zuweisen. Das erstellte Sub-Vi kannst im übergeordneten Programm damit einfügen, wenn du im Blockdiagramm mit der rechten Maustaste das Menü öffnest und mit "Vi auswählen" die betroffene Datei auswählst und einfügst. Danach kannst du die Ein- und Ausgänge in deinem Programm ansteuern.

LabView kann sehr viel, so dass ich auch noch nicht für alle Problemstellungen eine Lösung parat habe, bin aber durchaus daran interssiert mein Wissenstand zu erweitern. Wenn wir ein Weg finden, wie wir die Dateien austauschen können, kann ich gern mal drüber schauen und vielleicht Verbesserungsvorschläge im Code geben. Das reine Visualisieren müsste rein theoretisch möglich sein durch Übergabe von Variablen.
Bei Messgeräten kommt es darauf an welche Schnittstelle die Geräte haben. Hier im Geschäft haben wir meistens RS232/RS485 und GBIB. Für GBIB haben wir allerdings einen teuren USB/GBIB Umsetzer von NI. Es gibt aber bestimmt auch andere...ansteuern tue ich die Geräte dann über Treiber oder die entsprechenden Schnittstellenbefehle.

Kannst mir mal erläutern, was du mit einem Websurfer meinst!
 
AW: LabView/ Wago I/OSystem

Hi nameless,

einem Websurfer kann zum Anzeigen und Steuern von Netzwerk-Frontpanel benutzen. Dazu muss man einen http-client in LabView einrichten und darunter kann man sich iin die Anlage loggen. Aber keine Ahnung wie das geht. Werde das ma ausprobieren, was du mir geschickt hast.

Habe auch eine e-mail an dich geschrieben. Ich hoffe du hast sie bekommen, dann könnten wir die Dateien austauschen.

Wir hören voneinander:)

MFG
 
AW: LabView/ Wago I/OSystem

Hallo,

habe ein SubVi erstellt und abgespeichert. Danach wollte ich es in meinem Hauptprogramm einfügen. Dieses macht er nicht. Er gibt mir eine Fehlermeldung raus: (LabView: Allgemeiner Fehler, Bei Laden des VIs... ist ein Fehler aufgetreten. LabView-Ladefehlercode 3:Frontpanel konnte nicht geöffnet werden.

Hast du dieses schon mal gehabt und was haben wir falsch gemacht?

MFG
 
AW: LabView/ Wago I/OSystem

Wohin hast du mir eine E-Mail geschrieben? Das ist ne komische Fehlermeldung...kenn ich bisher nicht. Zur Abstimmung...welche LabView Version hast du?
 
AW: LabView/ Wago I/OSystem

Ich habe LabView 2011.
Als ich deinen Namen angeklickt habe, konnte ich über Technikerforum eine e-mail versenden. Ich dachte es zumindest, dass die ankommt.
Schade!
Ich verzweifel auch grad ein bißchen. Wollte heute die digitalen Ausgänge des Wago I/O System ansteuern aber nach vier Stunden habe ich es aufgegeben. Zumindestens für heute.
Habe auch SubVIs einbinden können, aber irgendwie wollte das Programm nicht.

Gibt es da eine bestimmte Methode wie man digitale Ausgänge ansteuern kann?

MFG
 
AW: LabView/ Wago I/OSystem

Ok, wie du wahrscheinlich mitbekommen hast, ist deine Mail doch angekommen. Ich hab gestern versucht auf deine Mail-Adresse etwas zu schicken, aber es konnte nichts zustellen. (nameless2@web.de) Dann bist ja mit LabView recht aktuell, dann musstest ja nicht unbedingt die Option "Anschlüsse anzeigen" anwählen, weil das Anschlussbild ja schon anzeigt. Schwierig zu sagen...muss dein Code mal anschauen.

Ich hab privat LV 2010 Studentenversion und im Geschäft LV 2012...
 
Zuletzt bearbeitet:
AW: LabView/ Wago I/OSystem

Hi ewiebe,

danke für die Hilfe.
Wir haben uns an Wago gewannt und die MBT.dll erworben bzw. wir dürfen sie ausprobieren, ob wir den controller ansteuern können.

Hast du soetwas schon gemacht? wenn ja wie bindet man die dll ein?

MFG
 
AW: LabView/ Wago I/OSystem

Das Einbinden kann ich dir auch zeigen...ich würde dir das eine oder andere Bild zeigen, aber deine Mail-Adresse hat nicht funktioniert...
 

Jobs

Jobmail abonieren - keine Jobs mehr verpassen:

Top