EGRU, LM4, Seite 60, Aufgabe 1

Hallo!

Bin grad noch in der Prüfungsvorbereitung für Sonntag:?

Könnt ihr die Lösung zu der Aufgabe aus den DAA-Unterlagen nachvollziehen?
Mein Kollege sind der Meinung, dass des nicht stimmen kann. ODER aber einfach zu blöd;) Dann könnte uns des evtl jmd erklären:D
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hi zven,

-vielleicht schreibst du noch welchen Teil ihr nicht versteht...
...dis Lösung in den Unterlagen stimmt jedenfalls

Gruss Uwe
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hmm, ich versuche es mal zu beschreiben.

Z.B. bei der grünen Led:

Die leuchtet ja, wenn der "open Collector" Ausgang des &-Glieds durchgeschalten ist.

Dazu müssten alle Eingänge des & "1" sein, oder?

Laut Datenblatt des SN74HC138 ist aber doch genau in den Temperaturbereichen 3-5 einer der Ausgänge Y3-Y5 "0", sodass das &-Glied eben nicht durchschalteto_O
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hi nochmal,

-euer "Denkfehler" liegt bei den LED's...
...die leuchten, wenn ein Lo-Pegel an der Kathode liegt
also ein Lo am Ausgang von einem UND-Gatter

ein Lo am Ausgang vom UND kommt sobald eine (oder mehrere)
Eingänge Lo sind...wenn alle Eingänge HI sind bleibt das UND inaktiv
(es kann ja nur auf Lo-Schalten, wegen dem OpenCollector)

Gruss Uwe
 
Zuletzt bearbeitet:
AW: EGRU, LM4, Seite 60, Aufgabe 1

Oh, danke für die Erklärung!

Unser Denkfehler lag dann aber eher am OC-UND.
wir dachten hald, der Ausgang ist durchgesteuert, wenn
die Eingangsbedingungen erfüllt sind, und sonst hochohmisch.

THX:D
 
E

elkos2701

Gast
Hallo,

kann mir vielleicht jemand erklären warum am mittleren UND Glied an einem Eingang die Spannung +UB angelegt wird?

Wenn die Ausgänge Y0, Y1 und Y2 einen H-Pegel haben ist doch am zweiten UND Glied auch ein H-Pegel, warum dann zusätzlich die Betriebsspannung?

Gruß Andreas
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hallo,

kann mir vielleicht jemand erklären warum am mittleren UND Glied an einem Eingang die Spannung +UB angelegt wird?

Wenn die Ausgänge Y0, Y1 und Y2 einen H-Pegel haben ist doch am zweiten UND Glied auch ein H-Pegel, warum dann zusätzlich die Betriebsspannung?

Gruß Andreas
die betriebsspannung ist für das erste und .. die bausteine mit open collector brauchen einen pull up widerstand.
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hallo, versteh ich das richtig wenn der Decorder von keinen Signal beschaltet wird, dass dann beide LED´s leuchten ???
 
AW: EGRU, LM4, Seite 60, Aufgabe 1

Hi nochmal,

-euer "Denkfehler" liegt bei den LED's...
...die leuchten, wenn ein Lo-Pegel an der Kathode liegt
also ein Lo am Ausgang von einem UND-Gatter

ein Lo am Ausgang vom UND kommt sobald eine (oder mehrere)
Eingänge Lo sind...wenn alle Eingänge HI sind bleibt das UND inaktiv
(es kann ja nur auf Lo-Schalten, wegen dem OpenCollector)

Gruss Uwe
Hallo Uwe und danke einmal für die knappe Erklärung. Diese Denkweise ist mir jedoch neu aber klingt logisch. Bitte nocheinmal, in meinen Worten, hoffe das es richtig ist.

Das & Gatter liefert dauerhaft ein 1 Signal bis der Fall eintritt, wenn Y3-Y5 ein 0 Signal ans & Gatter liefern. Nur in diesem Fall gibt das & Gatter ein 0 Signal raus. Auf Grund des Open Collectors wird das Signal auf Masse gezogen und die LED leuchtet nur in diesem Fall...
Sprich, das & hat dauerhaft 1 Signal am Ausgang -> LED leuchtet nicht | Bis auf die 3 Möglichkeiten wenn Y3-Y5 das & beinflussen und es am Ausgang eine 0 ausgibt -> dann leuchtet die LED

sehe ich das so richtig :) ??

Gruß MoLa
 
Hallo,
könnte mir evtl mal jemand erklären, was der Grund dafür ist wieso das erste und das zweite UND an dem Pull Up Widerstand hängen und das dritte UND was für die Grüne LED zuständig ist keinen Pull Up Widerstand benötigt?:mad: Das Bild spiegelt die Lösung wieder (LM4, Seite 89)
Danke :-)
 

Anhänge

Für mich ist das nutzen von +Ub nur ein durchschleifen eines "pull-up" an das 2.&-Gatter, für den Fall eines Low-Signals an Y0,1,2.
Einfacher wäre ein 5er& Gatter gewesen (Funktionsgleich zum &-Gatter für die grüne LED)

Lg Lakost
 
Hat jemand jetzt eine Lösung für den Pull-Up-Widerstand?
Sobald einer der Eingänge ein 0-Signal liefert, hat das UND-Gatter als Ausgang doch auch 0.
Da es nach unten mit dem zweiten UND-Gatter verbunden ist, und dieses daraufhin auch ein 0-Signal liefert, ... Warum ist dann dieser Pull-Up-Widerstand noch vonnöten?

Gruß
Dustin
 
Hallo Zusammen
Ja die Aufgabe scheint wohl einige schon beschäftigt zu haben ....
Stecke gerade an der typischen Stelle fest .....
Anschluss der Grünen LED über das UND mit Open Kollektor i.O. ABER
1. Anschluss der Roten LED, Y0 bis Y2 auf ein UND --> OK warum aber diesen Ausgang nicht an die Kathode der LED? sondern an den Pull up
2. 2tes UND Y6 und Y7 ok und der offene Eingang auf über einen Pull up definiert. Dann der Ausgang auf die Kathode der LED?
Wäre super wenn jemand mir hier auf die Sprünge helfen könnte!
Danke & Gruß
E.
 
Top