Brummen in Audioschaltung

Hallo, ich bastele gerade an einer Audioschaltung und habe dabei leider das Problem, das meine Lautsprecher zu brummen anfangen.
Ich habe schon ein bisschen recherchiert und das Problem auf zwei Ursachen eingegrenzt. Meine Hoffnung ist, dass mir hier vllt. jemand helfen kann es auf eine Ursache einzugrenzen 😉.

Kurz zu meinem Setup:
Ich besitze einen alten CD-Spielers, in den ich einen Raspberry Pi Zero mit einem HifiBerry-HAT einbauen möchte. Hinter dem Netzteil und Gleichrichter liegen ca. 17V Gleichspannung an, die ich mit einem StepDown-Spannungswandler auf 5V bringe.

Das Problem:
Wenn ich den Audio-Ausgang des Pi-Hats mit dem Audio-Eingang des CD-Spielers verbinde, gibt es ein starkes Brummen. Verbinde ich den PI mit normalen Kopfhörern, kann ich das Brummen nicht feststellen. Nutze ich ein externes USB-Netzteil, kann ich auch beim Anschluss an den CD-Spieler kein Brummen hören.

Mögliche Ursachen:
Nachdem ich jetzt viel Probiert habe, würde ich zwei Ursachen in betracht ziehen:
  1. Der Stepdown-Wandler erzeugt eine Ausgangsspannung die "zu dreieckig" ist und stört meinen Audioausgang. Dagegen würde allerdings sprechen, dass ich das Brummen auf den Kopfhörern nicht hören kann.
  2. Ich habe eine "Brummschleife" gebastelt. Hier kenne ich mich allerdings noch nicht so aus und man findet ziemlich widersprüchliche Aussagen bzgl. der Ursachen und möglichen Lösungen.
Hat hier jemand Ahnung von dem Thema und könnte mir eine Lösung nennen oder mich auf den richtigen Weg bringen?
Danke schon mal im Vorraus.
 
Wenn du normale Kopfhörer ansteuerst, muss das Spannungssignal doch viel höher sein als für einen normalen Audio Eingang!? Kann es sein das der Ausgangspegel deine Pi einfach zu hoch ist?
 
Hinter dem Netzteil und Gleichrichter liegen ca. 17V Gleichspannung an, die ich mit einem StepDown-Spannungswandler auf 5V bringe.
Und die Wahrscheinlichkeit ist sehr gross, dass da auch das Brummen herkommt.
Versuch es mal mit alle Erden, Massen und wenns geht auch noch den Minus zusammenzuhaengen.
Das koennte das Brummen verringern.
Wenn nicht, hast Du definitiv eine Schwierigkeit mit der Sauberheit der Spannung.
Filter helfen da.
 
Du hast die CD-Player-Versorgungsspannung benutzt und mit deren Masse wahrscheinlich eine Brummschleife gebaut, die natürlich nur zum Tragen kommt, wenn eine Audio(Masse)Verbindung zum CD-Player angeschlossen wird.
Vielleicht hilft eine abgeschirmte Leitung, deren Schirm nur einseitig auf Masse liegt und nur das Signal weitergeleitet wird, dann wäre die Schleife unterbrochen - geht nur, wenn die Masse von Zusatzplatine, Stromversorgung und CD-Player die Gleiche ist.

Was genau machst Du mit dem Ausgang des Pi, wo wird der angeschlossen?
Die Probleme von der Backe bekommst Du vermutlich mit einem DC/DC-Konverter, der eine "galvanische Trennung" bietet, oder einer separaten Versorgung über ein 5V-Netzteil, das von der 230V-Seite versorgt wird.
 

derschwarzepeter

Mitarbeiter
Und die Wahrscheinlichkeit ist sehr gross, dass da auch das Brummen herkommt.
Das kann man ausschließen, denn moderne Step-Down-Wandler arbeiten im zig-kHz-Bereich.
Das wird schon so sein, wie Läutewerk schreibt: Brummschleife.
Aus Erfahrung im Verstärkerbauen rate ich dir,
die Masseleitung = Schirm von Signalleitungen nur EINSEITIG auf Masse zu legen,
in der Regel am Ausgang und am Eingang der nächsten Stufe über einen 100nF zu erden.
Die MAsseleitungen der einzelenen Baugruppen müssen sternförmig auf einen zentralen Massepunkt führen,
den man z.B. am Netzteil dort macht, wo der + und der -Ladeelko zusammengeschaltet sind.
 
Top