szmtag

Frequenzumrichter parametrieren mit Problemen

Dieses Thema im Forum "Steuerungs- und Regelungstechnik, SPS" wurde erstellt von gm1, 5 Juli 2008.

  1. gm1

    gm1

    Hallo!
    ich habe mir einen kleinen Aufzug gebaut. Ja, richtig ein kleines aber verrücktes und schönes Teil. jetzt noch die Steuerung gebaut und fertig aber.....

    Ich bekomme den Siemens MMV220 nicht ordentlich parametriert um eine Hydraulikpumpe anfahren zu lassen.

    Erstmal zum Umrichter:
    Siemens Micromaster Vector MMV220. Hier der Link zum pdf
    Die wichtigen seiten sind die ab seite 35, die Parametereinstellungen.

    Der Motor:
    Ein Drehstrommotor mit Stern oder Dreieckschaltung
    Leistung 1,5 kw
    Max Strom 3,6/6,3A (je nach Schaltung)
    cos 0,79
    1420 U/min
    Angeschlossen an eine Hydraulikpumpe


    Was möchte ich erreichen?
    -ich möchte, dass der FU mit einer rampe von mir aus mit 3 Secunden auf 50 Hz fährt und anschliessend wieder runterfährt. Mehr nicht!
    Ansteuern über die Klemmen ist schon erledigt.



    Was passiert bei meinen Einstellungen?
    Alles eingestellt, siehe Parameter ab Seite 35 vom pdf

    Der FU läuft, wenn ich P002 (Hochlaufzeit) auf 0 setze. Setze ich die Zeit rauf, so kommt ein Hochfrequenzpfeifen und der Motor hat Mühe anzufahren, der Motorstrom steigt auf 9-12 A an nichts geht. Bei mehrmaligem Drücken, kommt er auch in Fahrt aber mit einem etwas zu hohem Strom.


    Meine derzeitigen Parameter:

    gerät in Auslieferungszustand gesetzt (kleine zahlen in Klammern) und diese Parameter geändert auf:

    P002: 3 Hochlaufzeit
    P003: 0 Rücklaufzeit
    P004: 20 Vorrundung in sec.
    P005: 50 Frequenzsollwert
    P006: 3 Frequenzsollwertauswahl
    P012: 10 minimale Motorfrequenz (wegen Dremoment)
    P071: 30 Schlupfkompensation
    P072: 250 Standard
    P076: 4 Pulsfrequenz
    P077: 2 Regelungsprinziep (auf quadratisch-Pumpenetc)
    P078 150% kontinuierliche Stromanhebung
    P079: 120 Losbrechmoment
    P080: 079 Motornennleistungsfaktor lt Typenschild
    P081: 50 Motornennfrequenz
    P082: 1420 Drehzahl lt. Typensch.
    P083: 3,6 (Stern) 6,2 (Dreieck) Motornennstrom lt Typenschild
    P084: 230 (Stern) 400 (Dreieck) Spannung lt Typensch.
    P085: 1,5 M.Nennleistung
    P086: 150% Motrostrombegrenzung
    P088: auch getestet -Autokalibrierung
    P089: 4,3 Ohm Slatorwiederstand (gemessen)


    meine Eindrücke:

    Die heftigste Änderung kommt bei P002 Hochlaufzeit. Steht sie auf 0, so geht es sofort und ohne Verzögerung ruckartig hoch. Strom 4-5 A

    Bei P71, der Schlupfkompensation passiert auch was aber ich komme nicht auf ein Ergebnis.
    Der Strom geht einfach auf max und das heisst 9-12A und der Motor dreht fast gar nicht. Geht halt in Überlast, wird sehr schnell warm.

    Anfangs habe ich gedacht, da blockiert was, der lauf stimmt nicht, also FU abgeklemmt und ein Schütz aufgeschaltet und eine gute Stromzange angelegt.
    Folge: 3,1-4 A und ohne zu mucken.

    Da mit FU der Motor auch nicht ganz sauber läuft, habe ich den verdacht, dass da was böse faul ist. Je mehr belastung, um so schlimmer wird das ganze.

    Die Autokalibrierung geht auch, jedoch kommt sehr schnell der Überstrom und der Motor hält nachdem er sich gequält hat.


    Ich bin mal gespannt, ob mir jemand helfen kann. Ich zweifel schon und das ist jetzt echt kurz vor dem Ziel!!!


    Vielen dank
    Gruss
    Frank

    Habe auch ein Video von dem teil, poste ich evtl :)
     
  2. AW: Frequenzumrichter parametrieren mit Problemen

    hi,

    ich hab mir mal das pdf angeschaut und mit deinen Parametern verglichen!
    mir sind 3 einstellungen aufgefallen, die deine probleme verursachen könnten:

    P002 auf min. 10s oder mehr raufsetzen ("...Das Einstellen einer zu kurzen Hochlaufzeit kann zum Abschalten des Umrichters führen (Fehlercode F002 - Überstrom)..."

    P006 auf 0 setzen ("...Digitalmotorpotentiometer. Der Umrichter läuft mit der in P005 eingestellten Frequenz. Diese kann mittels der Tasten D und Ñ eingestellt werden.. Ist P007 = 0, kann die Frequenz durch zwei Binäreingänge gesteuert werden (P051 - P055 oder P356) auf die Werte 11 und 12 einstellen...")

    P078 die % runtersetzen! ("...WARNUNG: Falls P078 zu hoch eingestellt wird, kann es zu einer Überhitzung des Motors und/oder einer Überstromauslösung (F002) kommen...")

    Mfg SW
     
  3. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen

    danke für deine Antwort!
    Morgen bin ich wieder zu Hause und werde es mal ausprobieren.
    das mit Parameter2 (P002) die Anlauframpe: Wenn diese auf 0 ist, läuft der Motor recht gut und nichts überhitzt oder stockt. Gut, ein kräftiger Ruck und die Drehzahl ist da, was ja nicht sein soll.
    Setze ich die Rampe hoch, auch 10sec, ging es ja gerade nicht mehr.
    ich werde die parameteränderungen ausprobieren und berichten.

    danke schonmal für Deine Hilfe!

    Frank
     
  4. AW: Frequenzumrichter parametrieren mit Problemen

    kein problem, immer wieder gern..

    ja sag dann mal bescheid wie es dann aussieht, wenn net besser geworden ist muss ich mir nochmal gedanken machen was man noch an den parametern ändern könnte!
     
  5. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen

    verstehe ich nicht ganz. Wo liegt der Unterschied?
    ich steuere doch nur (bis jetzt) uber die Klemme 5 mit 24V+ digital an, also "Ein", Rampe soll beginnen. Was soll jetzt geändert werden? Stell ich das parameter um, reagiert der Eingang auf Klemme 5 nicht mehr. (weiss jetzt auch nicht so recht was ich jetzt mit binär anfangen soll, bin da leider kein Profi, sorry)
    Ändert sich dann was an der Konfiguration oder vielleicht nur an dem bislang gewähltem Eingang zum Ansteuern des FU?


    Stell ich die Rampe von 0sec (die ja so recht perfekt geht bis auf dass ich es so nicht haben will) auf 5 oder 10 sec, geht der motor sofort auf Richtung 12A und höher..... und schaltet ab, der motor läuft leicht an oder auch nicht, tut sich mehr als schwer.
     
  6. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen

    Soooooo.....

    Ich bin einen riesen Schritt weiter!
    Ein guter Bekannter hatte die letztendliche Lösung gefunden. nachdem ich mit einem Freund schon fast zwei nachmittage mit der Parametrierung und Fehlersuche verbracht hatte, die Hilfe hier im Forum gesucht habe, hat letztendlich ein Maschinenbauer die letztendliche Lösung gefunden. Aber auch er hat 2 Stunden gebraucht.

    was wurde gemacht?

    nach dem Durchgang aller Parameter ist er besonders über
    P071 Schlupfkomensation
    P076 Pulsfrequenz
    und als allerwichtigsten P79 Losbrechmoment.

    Nach den o.g. Parametern, über die er sich gedanken machte, setzten wir als erstes die Schaltung wieder als Sternschaltung und änderten die Parameter
    P083 Motornennstrom von 6,2A auf 3,6A
    P084 Motornennspannung von 220V auf 400V

    warum der Motorstrom aber so weit hochschnellte, als der Umrichter in der Steigung hochlief, lag seiner Meinung nach nur in der Dynamik und damit in Verbindung stehenden Leistung, die damit fällig wird. Will heissen, der Umrichter versucht mit aller Kraft die Frequenz zu halten, die ihm die Rampe vorgibt. geht der Strom hoch, liegt der haken in der Sollfreqenz. Diese runter auf 35Hz und schon lief er beachtlich besser aber nur in Stern und mit passender feinabstimmung. Erst der Losbrechmoment, der hochgedreht wurde (weil Zahnradpumpe mit Sofortbelastung) und etwas Schlupfkompensation von 30% und Pulsfrequens auf 8Hz ging es. Die Rampe, die jetzt gesetzt wurde, liegt bei 3 sec. genau hier läuft die Kraft, die wir brauchen. Also kurz Power und dann tippelt die Pumpe mit max 3A hoch.

    Die Pumpe musste zu viel leisten und der Frequenzumrichter ist auch nicht zu gross ausgelegt. warum aber alles lief, ohne Umrichter, liegt daran, dass die Stadtwerke ein sehr viel grösseres Anlaufmoment ermöglichen als mein FU. Für die Zeit der Rampe hatte ich einfach zu wenig Tinte auf dem Füller. Man könnte den Schlauch für das Öl vergrössern um weniger Wiederstand zu haben.... egal.

    dann habe ich noch P006 auf 2 gestellt, den Initiator für die Verlangsamung kurz vor Ende habe ich als Schliesser mit 24V+ auf Klemme 16 am Umrichter angeschlossen und die Minimalfrequenz von P012 auf 25Hz gestellt.

    was ich noch nicht genau hinbekommen habe, ist dass er die Frequenzverlangsamung recht schlagartig vornimmt, ein Ruck. Hier konnte ich keine Rampe finden.


    Weil mir hier so viel geholfen wurde, habe ich mal ein Bild von der Schaltung und ein Video von der fertigen Funktion gepostet!

    Clickme: Schaut Euch dazu auch das Video an.


    Hier noch eine Variante vom Prototp, als ich den ersten Probbelauf hatte aber ohne Schaltung, ohne Sicherung, ohne Frequenzumrichter, ohne Endschalter.... Click hier: YouTube

    Vielen Dank nochmal,
    Sie das alles anzulesen kostet echt Zeit, weiss es wirklich zu schätzen!
     

    Anhänge:

  7. AW: Frequenzumrichter parametrieren mit Problemen

    hi,

    is doch super, hatte die letzten paar tage keine zeit miur das nochmal anzuschauen (stress auf arbeit).

    ein skriptvirus bei deinem video???

    mfg SW
     
  8. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen

    Virus? nee, das sind original Programme.
     
  9. AW: Frequenzumrichter parametrieren mit Problemen

    also so bald ich den link zum video anklicke, schlägt mein anti-vir alarm!!! das soll ein skript-virus in der datei sein!

    Virus-meldung: HTML/Dldr.Iframe.EH
     
  10. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen


    Siehe Anhang!

    Ich habe gesagt, dass ich nur original Software benutze und nie auf die Idee käme einen Virus hier unterzujubeln. Sicher ist man nie, das stimmt aber ich habe das Video gerade noch mal getestet.
    Viele Antivirenprogramme reagieren recht heftig auf bearbeitete oder selbst geschnittene Filme, vielleicht ist es bei Dir genau so?
    Wenn Du Dir so sicher bist, dass Du einen Schaden von dem Film bekommst, so klick ihn halt nicht an. Wenn sonst wer einen Virus angezeigt bekommt, so kann er es ja posten. Ich kann nichts finden.
    danke aber für den doppelten Hinweis ;-)
     

    Anhänge:

  11. AW: Frequenzumrichter parametrieren mit Problemen

    Hallo,

    also ich hab mich dennoch getraut, das Video abzuspielen!

    Bekomme keine Virusmeldung und benutze ebenfalls Avira AntiVir

    Respekt Frank!
     
  12. AW: Frequenzumrichter parametrieren mit Problemen

    @gm1:
    Geiles Teil! Respekt vor solch einer Arbeit!
     
  13. AW: Frequenzumrichter parametrieren mit Problemen

    also ich hab mir das zu hause auf meinem pc angeschaut, keine meldung von antivir, komisch (scheiss pc auf arbeit).....

    respekt, geile sache so ein aufzug...

    aber was machts du wenn der strom mal ausfällt oder der aufzug defekt ist, wie kommst dann hoch??? ne treppe als alternative vorhanden???
     
  14. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen

    Ihr bekommt auch keinen Virus!!!! ..das wäre ja noch was...

    was ich dann mache?
    Gut, erstmal ein dummes gesicht :) Das ist der blödeste Moment, wenn man gerade so hoch ist, das es zu hoch ist einfach mal runter zu klettern und zu niedrig um zu klettern. Aber sonst habe ich natürlich noch eine Treppe, nur die geht durch das Treppenhaus. Das sind zwei getrennte Wohnungen die ich verbunden habe. Die untere Wohnung ist klein und liegt genau unter dem Wohnzimmer. Ein Loch für eine Treppe wäre 3,5 lang und 1,2 Meter breit gewesen. der Raum oben wäre dahin. Eine Alternative gab es nicht wirklich. Im Treppenhaus laufen auch andere Mieter rum, tagsüber halt auch Patienten zu eine Praxis.... da ist es nicht so prall mit Unterwäsche mal ebend ins Schlafzimmer zu gehn ;-)

    -----------------------------------------

    Danke für die netten, lobenen Worte.
    Es war echt heftig, sowas zu bauen. Ich selbst habe das ganze sehr unterschätzt und habe mir das sehr viel einfacher vorgestellt.

    Schnell merkte ich, dass ich mit dem Zeichenbrett nicht weit kam, musste AutoCad lernen. dann Schweissen, Metallbau... auch noch wenig Plan. Das Elektrische habe ich mir auch nur so angeeignet obwohl ich da auch sagen muss, dass mir ein Freund bei der Schaltungsplanung sehr geholfen hat.
    Das war ein echter Maraton und jetzt bin ich froh es geschaft zu haben!

    Beruflich bin ich weder Elektriker, noch Schlosser oder Zeichner....
    ...aber dafür bin ich jetzt auch stolz das hinbekommen zu haben.
     
    Zuletzt bearbeitet: 18 Juli 2008
  15. AW: Frequenzumrichter parametrieren mit Problemen

    Dann noch mehr Respekt, wenn du sowas als Laie auf die Beine gestellt hast!
    Was machst du denn dann beruflich bzw. hast gelernt, wenn ich mal so fragen darf
     
  16. gm1

    gm1

    AW: Frequenzumrichter parametrieren mit Problemen


    -> Zahntechnikermeister :rolleyes:
     
  17. AW: Frequenzumrichter parametrieren mit Problemen

    Dann hast Du sicher hydraulisch ausfahrbare Zähne in Deinem Sortiment!;)
     

Diese Seite empfehlen